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Legal information

Subject to technical change without notice.

This Program help has been prepared based on DIN EN 82079-1. The content was 
compiled with the greatest care and attention and reflects the latest information 
available to us.

We should nevertheless point out that this document cannot always be updated in 
line with ongoing technical developments in our products.

Information and specifications may be subject to change at any time. For information 
on the latest version please visit www.lti-motion.com.

Copyright ©

The entire contents of this documentation, especially the texts, photos and graphics 
it contains, are protected by copyright. The copyright is owned by  LTI Motion GmbH 
unless specifically marked otherwise.
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1  General
The product DVD for LTI Motion GmbH contains the complete documentation for the 
respective product series. The documentation of a product series includes Operation 
Manual (hardware description), Device help (software description) and other User 
manuals (e.g. field bus description) and Specification. They are available in PDF 
format.

1.1  Target group
Dear user,

This documentation is an integral part of the device and contains important 
information on operation and service. It is aimed at everyone who performs 
mounting, set-up, commissioning and service tasks on the product.

1.2  Requirements
Requirements for using LTI Motion GmbH:

 l The documentation for the devices must be legible, accessible at all times 
and kept for the product’s entire service life.

 l The user must read and understand the device documentation.

 l Qualification: To avoid bodily injury and property damage, only qualified 
personnel with electrical training may work with/on the device.

 l Required skills and knowledge:
- national accident prevention rules (e.g. DGUV V3 in Germany)
- How to set up, install, commission and operate the device
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Work related to other specialised areas, such as transportation, storage and 
disposal must be performed exclusively by appropriately trained personnel.

NOTE

 l This Program help applies for the DriveManager 5.

 

1.3  Pictograms
The pictograms used in this Program help have the following meaning for the user:

NOTE

 l Useful information and special notes.

 l Reference to applicable documents.

 



1.4  Exclusion of liability
Compliance with the documentation for the devices of  LTI Motion GmbH is a 
prerequisite for:

 l safe operation and

 l attaining the performance characteristics and product characteristics 
described.

LTI Motion GmbH accepts no liability for personal injury, material damage or 
financial losses arising from disregard of the documentation.

 

1.5  Applicable documents

All of the further applicable documents for this device can be found on our 
website:

www.lti-motion.com at

ServoOne Single-axis system

ServoOne Multi-Axis System

ServoOne junior

ServoOne CM
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1.6  Support  
  

Address: LTI Motion GmbH 
Gewerbestrasse 5-9 
35633 Lahnau 

Our Helpline helps you quickly and expertly if you have any technical questions 
concerning project planning for your machine or commissioning your device.

The Helpline can be reached by email or telephone:

Service hours: Mon–Fri: 8 am–5 pm (CET)

Email: helpline@lti-motion.com

Phone: +49 6441 966-180

Internet: www.lti-motion.com

 

NOTE

 l For detailed information on our services, please visit our website 
www.lti-motion.com ►Service ►Tailored Service Offers [direct 
link].

http://www.lti-motion.com/soac
http://www.lti-motion.com/sodc
http://www.lti-motion.com/soj
http://www.lti-motion.com/socm
mailto:helpline@lti-motion.com
https://lti-motion.com/
https://www.lti-motion.com/de/service/dienstleistungen
https://www.lti-motion.com/de/service/dienstleistungen
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2  Safety

2.1  Overview
Our devices are designed and built with the latest technology and comply with all 
recognized safety rules and standards. Nevertheless, there are potential hazards 
that may arise during their use. In this chapter:

 l We provide information regarding the residual risks and hazards posed by 
our devices when they are used as intended.

 l We warn you about foreseeable misuse of our devices.

 l We point out that it is necessary to exercise due care and caution and go 
over measures designed to minimize risk.

2.2  For your own safety
NOTE 
When installing and commissioning your device, you must observe the 
documentation for the relevant device family!

NOTE 
Please also observe the safety information and warnings in the 
respective applicable operation manual, especially when commissioning 
the drive!

NOTE 
Pay attention to special safety information and warnings which are 
presented here in the document directly before a specific activity is 
described and which warn the user of a specific hazard!
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Our devices are fast and safe to operate. For your own safety and to ensure reliable 
operation of your machine, take note of the following:

Step Action

1.

Precautions to avoid injury and damage to property

Ensure there is no possibility of bodily injury or damage to the machine 
when testing and commissioning the device.

2.3  Safety information and warnings
Our devices may pose certain hazards. Therefore, always observe the following 
safety information and warnings.

WARNING! Risk of injury posed by uncontrolled rotation!

Improper conduct can lead to serious injury or death.

 l Before commissioning motors with a feather key at the 
shaft end, the key must be secured to prevent it from 
being ejected if this is not already prevented by drive 
elements such as pulleys, couplings, etc.

CAUTION! Your system/motor may be damaged if put into operation in 
an uncontrolled or inappropriate manner.

Improper conduct can cause damage to your system / 
machine.

 l Before the “Start” step, make absolutely sure that a valid 
setpoint has been entered, as the configured setpoint 
will be immediately transmitted to the motor after the 
motor control function starts, which may result in the 
motor accelerating unexpectedly.



CAUTION! Damage to the device as a result of incorrect operation!

Failure to exercise caution or follow proper working 
procedures may result in damage to the device.

 l The mains voltage for the power supply must not be 
switched on until after the available mains voltage 
setting has been configured in the device firmware and 
the device is restarted (in the event that the mains 
voltage or the switching frequency has been changed).

2.4  Responsibility
Electronic devices are not fail-safe. The company setting up and/or operating a 
complete machine or system is responsible:

 l For ensuring that the motor will be brought to a safe state if the device fails.

 l For the safety of persons and machinery.

 l For proper functional capability of the complete machine.

 l For the risk assessment of the complete machine or system acc. to 
DIN EN ISO 12100:2011 and EN ISO 13849-1.

Observe the topic “Electrical equipment of machines” in EN 60204-1:2006 “Safety of 
machinery”. 
The safety requirements defined there to be met by electrical machinery are 
intended to ensure personal safety and the safety of machinery or systems.

The emergency-stop function (to EN 60204-1:2006) shuts down the power supply of 
a machine, which leads to uncontrolled rundown of the drives. In order to prevent 
hazards, check whether the following will be required:

 l To keep individual drives running. 

 l To initiate certain safety procedures.
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 l To provide an emergency-stop function (emergency-stop function: movement 
stopped by “switching off the electrical power supply” or STO Safe Torque 
Off).

 



3  The Help System

3.1  Overview
The help feature in the DriveManager 5 is divided into several areas and also offers 
further opportunities for the user to obtain information on the system, the device or 
on the parameters.

The following three areas can be found in the main menu under the “Help” menu 
item:

 

Program Help:  
This opens the help feature which explains the program, or the user interface itself, 
including the structure, the menus, the windows and the functions involved in 
operating it.

Device Help:  
This Help offers the operator all the information on the device, the device family, 
software functions, parameters, etc.

Information about: 
Here, general information on the DriveManager 5  can be found. An overview of all 
installed plug-ins with the version shown can be found under Details.
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Context sensitive help  
In nearly all areas in which it is possible to open a menu window using the right 
mouse button, the context sensitive help menus can be found.

This opens the correct Help for the respective topic.

 

Direct information on the parameter properties (F2 Parameter help)

Detailed information on the respective parameter can be found using F2 Parameter 
help directly (see Parameter help).



3.2  Help window / Help browser
When DriveManager 5 Program help is opened, the help window opens in the 
workspace.

When the device help is started, however, a selection window appears first in which 
the desired device and the language must be selected. After this, the available types 
of help for this device are displayed.

Fig. 3.1: Pre-selection window for opening the correct device help
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Fig. 3.2: The help window with navigation pane and help pane (device help)

Searching for a help topic

If the help is not opened via a context-sensitive source directly from a topic, but 
manually instead, the desired search result can be found using three different 
options in the navigation pane.

 1. Searching in the contents tree

 2. Searching via the index

 3. Searching using the search window



The order of these three navigation pane items can be changed if needed and it is 
also possible to hide items.

Fig. 3.3: Customizing the navigation pane options
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Fig. 3.4: The contents, index and search windows in help

 

DriveManager 5   as a separate help browser

When help is used frequently, it is useful to employ DriveManager 5 as a separate 
help browser. To do so, a second instance of DriveManager 5 must be opened. 
Here, after starting the desired help, all of the windows except the help window can 
be closed. The result is that the help is then available to the operator in its own 
Windows pane of any desired size in its own Windows task. This makes it possible to 
toggle quickly between the help and the DriveManager 5 itself via the Windows task 
toggling feature.



Fig. 3.5: DriveManager 5   as a help browser in a separate Windows pane
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3.3  F2 Parameter Help
In order to provide the user with comprehensive information on each parameter, 
DriveManager 5 offers the Parameter Help. This can be opened by clicking on a 
parameter field in the desired dialog box and then pressing the F2 key. A window 
opens containing the parameter properties with all of the information which concerns 
the respective parameter.



Fig. 3.6: Information window with the parameter properties

Device Help: The Device Help can be opened directly from the parameter properties 
window and it then shows the appropriate explanation for this topic.
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Export: The "Export" button can be used to generate and display a text file with the 
contents of the parameter properties. This can then be saved and processed further.

Help: This opens the Program help

Cursor sensitive display: When this function is enabled, simply moving the mouse 
over the parameter immediately refreshes the display of the parameter properties for 
this parameter.

 

Tooltip display for parameters with a change field

With some parameters, the parameter number is not displayed directly. When the 
mouse is moved over the input field, the system displays a tooltip (a small pop-up 
information window) containing the parameter number, the name and a brief 
explanation; see the figure.

Fig. 3.7: Parameter tooltip function



4  Installation
A detailed description concerning the installation of DriveManager 5 can be found in 
the installation manual.
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5  The user interface

5.1  General user interface information
High degree of flexibility and customization by the user

During the development of the user interface, careful attention was given to ensuring 
that every user has the ability to adapt it to exactly suit their own needs because of 
the wide array of operator requirements. The arrangement and size of the individual 
windows, the menu bars and the general option settings can be configured 
completely at will.

The user interface philosophy

Many parameters and functions can be reached in various ways using different 
options. This has led to the development of very different approaches to working with 
and operating the user interface. For example, some users work without using any 
project windows whatsoever, instead using only menus and icons and by switching 
the “active device” while others use the project tree exclusively enabling them to 
access the desired parameter field or window of the desired device with a single 
click.
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5.2  The default desktop
When DriveManager 5 is started, a predefined user interface opens with all its 
toolbars and windows. Depending on the display and window size a well as the 
resolution, some of the window content is displayed only in tabs at the side which 
can be opened.

The defined default desktop can be modified to suit the requirements. All three 
toolbars can be shown or hidden as desired using the main menu under Extras > 
Customize > Toolbars.

It is possible to create, save and later load several user interfaces. If things get out of 
hand, the default view can be restored at any time in the main menu under Active 
device > Load standard desktop.

Views of the default desktop, dependent on the window size



 

Overview of the menu/toolbars, windows and workspaces

ID No.: 0842.05B.3-02   version: 06.2019 DriveManager 5   Program help 18

5  The user interface

5.3  Customizing the user interface/desktop
The user interface of the DriveManager 5 can easily be customized to suit one’s 
needs and the working conditions.

All windows can be positioned anywhere or can be anchored at the right edge of the 
screen as tabs. A customized desktop can be saved and thereby becomes part of 
the project.

The various dialog boxes that are hidden can be opened in a number of ways, for 
example, via the quick launch bar in the main menu under >View or else under 
>Window. It first appears at the side of the screen and can be positioned anywhere 
on the user interface using "Docking Views”–Technology. Clicking and holding the 
respective toolbar with the mouse and moving it makes the window become the 
focus and it is indicated by means of a blue field. Now it can be navigated to the 
central arrow cross or to an individual docking arrow. Anchoring takes place when 
the mouse button is released.



Moving and anchoring a window

 

Additional modification options for the window

All windows can be anchored, hidden and detached once again.

The small black arrow key represents a menu with the following window options:
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 n Floating: The window is detached from the anchor at the side and can be 
moved at will. The colour of the toolbar changes from grey to blue when the 
window is the focus.

 n Dock: This item becomes available with a click in the title bar of a freely 
moveable window using the right mouse button:

 n Auto Hide: The window is no longer shown on the active user interface and 
is instead shown only as a tab. It can be highlighted once again as needed 
using the tab, the quick launch bar or the main menu.

 n Hide/Close: The window is closed and if needed, must be opened again via 
the quick launch bar, the main menu or the project tree.



The function "Auto Hide" minimizes the window to a tab at the edge of the screen. 
Clicking on the tab with the cursor opens the window again (depending on the type 
of anchor, the needle may be displayed rotated by 90°).
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5.4  Saving and loading a desktop
After customizing a desktop individually, it can be saved and loaded again later. The 
following icons are available in the upper standard bar.

Save a new desktop

Load an existing desktop

The settings must be saved so that they can be called up again at a later point in 
time.

Moreover, in the main menu under Extras > Customize, there is another item for 
these two menu items which allows the user to make their own user interface 
(desktop) be the default user interface.

 



5.5  The menu bar and toolbars
The menu bar and toolbars are dependent on the topic and are divided into four 
different areas:

 n The main menu

 n The standard bar (general functions, independent of the device)

 n The basic operations of the active device

 n The quick access bar (subject area bar): Access to the individual subject 
areas of the active device

The quick access bar currently contains 17 icons of the respective subject areas. 
Depending on the window width, only some of these are visible, while the others are 
hidden in a fold-out menu as shown above.

5.5.1  Showing/hiding toolbars
All three toolbars can be shown or hidden as desired using the main menu under 
Extras > Customize > Toolbars.

5.5.2  An overview of the standard bar
The following functions are available both offline and in online mode.
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Icon Function/Description

Open the project wizard

Selection: New project, new scope plot container or new 
smart PLC sequence program

Selection: Open project, open digital scope record, open 
device settings, open message logger, open smart PLC 
sequence program and open file

Save the file currently open in the workspace

Save all open files

Print the workspace

Add a device to the project

Remove a device from the project

Compare settings (devices or files)

Selection of the user level (authorized persons: observer, 
setter, local and global administrators, internal to device)

Save desktop layout

Table 5.1:   The standard bar functions



Icon Function/Description

Open or load desktop layout (with selection menu)

Expand/restore document view

Start Program help

Table 5.1:   The standard bar functions (continue)

 

5.5.3  Overview of the basic operations of the active 
device

Icon Function/Description

Undo last changes of selected page

Repeat last undone changes

Establish or disconnect communication in the project

Display the active device and possibility to switch the 
active device

Table 5.2:   Basic operations of the active device
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Icon Function/Description

Save current device settings in file

Transfer device settings from file to device

Save device setting persistently in device (RAM to ROM)

Open the digital oscilloscope (work with the digital 
scope)

Create device commissioning file

Load device commissioning file

Table 5.2:   Basic operations of the active device (continue)

 

5.5.4  Overview of the quick access bar for the individual 
subject areas of the active device
If the quick access bar or the subject area bar is currently shown, it is possible to 
open one or more of the 17 subject areas of the active device.



When several subject areas are open, some of them will be displayed as a separate 
window or a tab above the central workspace; see figure. A click on the arrow allows 
all open subject areas to be displayed together.

Documents and/or display windows can be closed via Main menu > Window. All 
open subject areas can also be selected there as menu items.
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5.6  The workspace: Graphic and list views
There are two different display modes for the workspace. For most subject areas, the 
user is able to switch between the graphic view (also known as the dialog box view) 
and the list view. The view can be switched by right-clicking in the workspace and 
choosing “Switch to graphic view or List view.” Dialog boxes are not present for all 
subject areas. In this case, only the list view is shown.

Graphical view of the workspace



List view of the workspace

In the list view, all parameters of the respective subject area are displayed with all 
parameter information; parameter number (ID), index, name, value, unit, description, 
data type, factory setting, minimum, maximum, reading and writing level.
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The context menu can be opened with a right-click in the parameter list window and 
here, further view options can be set, such as “Expand all” or “Collapse all”.



5.7  User-defined parameter list
The user defined parameter list allows the user to create their own parameter list. It 
can be used to assemble parameters from different subject areas in list form. They 
can then be edited directly without having to open the corresponding subject areas.

Procedure for creating a user defined parameter list:

 n Open the desired subject area and in the workspace, switch from the graphic 
view to the list view.

 n Open the user defined parameter list in the main menu under View > User 
defined parameter list.

 
In the workspace, an additional blank window opens in which one’s own 
parameter list can be managed. Here, the settings can be loaded, saved and 
also deleted.

 n Now mark the parameters which are to be selected (multiple selection in 
typical Windows manner possible) and drag them into the user-defined 
parameter list using drag and drop. Before the selected parameters can be 
moved, the cursor must change from the arrow display to an arrow with a 
rectangle and a plus sign. The change of the symbol takes places as soon as 
the arrow of the cursor is moved over the line between two parameter lines. 
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 n Open additional subject areas and add new parameters as needed.

The user defined parameter list is saved as well when the project is saved.



5.8  User level (access restrictions)
DriveManager 5 has five user levels to provide different parameter access 
restrictions. By default, the highest user level that is not password protected opens, 
which can be the “Local Administrator”, for example. This level allows selection of all 
parameters and functions which are adequate for 95% of all applications. The levels 
"Administrator" and “Internal" are only available to authorized users with the 
corresponding password.

Display and modification options

 n Via the standard bar
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 n or via the main menu: 

 

Access to the parameters can be protected additionally apart from the user levels. 
Passwords can be assigned as desired to block access to the device for non-
authorized people.

Further information about this can be found in the next Section "Password" on page 
27 .



The five user levels

User level Description Password pro-
tection

Observer Read access only OFF

Setter Restricted read and write access OFF

Local 
administrator

Factory setting: Read and write access to 
all parameters OFF

Administrator In-house company user level: Access 
blocked ON

Internal Developer access: Access blocked ON

Table 5.3:   The user levels with permissions
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5.9  Password
Four passwords can be assigned in order to specifically control access to the device 
settings.

 n Passwords 1 and 2 are for securing the levels of “Setter" and “Local 
administrator."

 n Passwords 3 and 4 are intended for the manual mode and data set 
operations.

The passwords are saved directly in the device.

Defining passwords:

In the project tree, open the subject area Administration > Passwords 
Or select the “Passwords” icon in the subject area bar (the icon is not available for 
every device in the subject area bar). 
Specify a password.

 

When the connection status changes from "Offline" to “Online," a password is 
requested. This query also takes place when the user level is changed.



Deleting or changing passwords

The procedure is the same as for specifying passwords. When doing so, the 
password must either be deleted or overwritten with a new one.

NOTE

A password is saved in the respective device and not in DriveManager 5. 
This ensures that a separate password can be assigned to every device 
in a network.
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5.10  Online/offline mode
No active connection (“offline”) between the operating software and the controller is 
necessary for the editing of a project or a data set.

"Offline” mode (no communication with the device)

In this mode, no active device is connected to the operating software. Nonetheless, it 
is possible to edit an existing project. The text in the project tree is blue. An offline 
data set can be saved and transferred to a device at a later point in time.

"Online” mode (communication with the active device)

The communication between the PC and the controller is established. All of the 
functions in DriveManager 5 can be used. Data sets can be changed and saved 
directly in the controller. In the “online” mode, the text in the project tree is black.

Establish or disconnect communication

There are different options in DriveManager 5 for establishing communication with 
the device, i.e. to connect or disconnect it.

 n In the “Basic active device actions” toolbar, the  icon is 
for switching between the online and offline modes.

 n In the main menu under Project > Go online (connect) or Go offline 
(disconnect)

 n In the menu line of the project window 

 n In the project tree it is also possible to use the context menu (right mouse 
button) to switch the desired device using “Online/Offline.”



5.11  Options / Options window
In the options window, special requirements and properties can be set for different 
areas.

In the main menu under Extras > Options, these properties are divided into ten 
separate subject areas.

All changes can be undone at any time using the “Reset to standard settings” button.

5.11.1  Project options
General, project-related settings can be changed here. The standard settings and 
options for changing them are self explanatory.
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5.11.2  Program start and end
Here it is possible to define whether a project should be opened automatically when 
the program starts, either with or without a prior query. The user can decide to 
specify the point in time for saving as when the program is exited or to have the 
project saved automatically.

5.11.3  International settings / language settings
The interface opens in the language in which the operating system has been 
installed. This language can be changed here. Under “Other language” a choice can 
be made between German and English.

The Installation wizard only operates in English. The language change can only be 
made once DriveManager 5 has been installed and opened.



5.11.4  Display / Visualization options
Various different display options can be modified here. For example, device names 
or acknowledgment errors can be suppressed or the defaults for certain windows 
can be defined.
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5.11.5  Cyclic operations (modifications to the refresh/up-
date rates)
If the computing performance is low, the refresh rate for the device display can be 
reduced. The device state monitoring and the device message monitor can be 
modified in the same way.

5.11.6  Directories
Selection of the storage path for the files of a project. The standard setting with the 
path c:\Users\Username\Documents\... can be changed here at any time.



5.11.7  Directories > Documents
 

All storage locations in which projects, device settings, oscilloscope recordings, 
protocols, etc. are saved are defined here and can be changed as needed. 

5.11.8  Project data maintenance
There are several archiving options for managing the project data:

 n Automatic clean-up of log files, with or without prior query

 n Setting of the time and/or days for the clean-up operations

 n Limitation of the data volume

ID No.: 0842.05B.3-02   version: 06.2019 DriveManager 5   Program help 31

5  The user interface

5.11.9  E-mail support
Options and configuration of the E-mail support.

Detailed information about this can be found in Section "Email function" on page 58.



5.11.10  Advanced functions
There are three settings for the Logging of parameter write accesses:

 n Program controlled: All actions which are configurable in the screens and via 
the parameter editor are logged.

 n Always, including automatic sequences: Writing access are logged as well 
which run in the background, e.g. parametrization operations which are 
triggered by the test signal generator.

 n Switched off: Logging is disabled.

Project device builder: If necessary deviations of the parameters between a firmware 
update and an older version are not to be displayed, it is possible to have all raw 
data be visible.

Initial commissioning: Selection of whether the initial commissioning dialog box 
should always be displayed when a new project is created.

Text collector dialog: Active for dictionary creation in the culture (language 
selection)
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If this function is activated, then another window opens in which a language can be 
selected.

If this options dialog is closed with “OK,” then all screens and dialog boxes which are 
subsequently opened are scanned. A dictionary for the previously selected 
language is created in the background. Afterwards, the options dialog must be 
opened once again and this function must be disabled. 
Then the dictionary is opened (consisting of two dictionaries; one for the device and 
one for the dialogs) and a translation can be entered in these dictionaries.

TCP/IP communication settings: Setting of the timeout time for the write/read access 
to parameters.



5.11.11  User authorizations
Making changes here requires the necessary user authorizations.
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Further information about user authorizations can be found in Section "Password" on 
page 27 and in Section "User level (access restrictions)" on page 26



5.12  Actual value display (cockpit)

The actual value display offers the user numerous displays of various different 
values, such as positions, speeds, torques, currents, voltages and temperatures of 
the controller, in dependence on the device that is connected. These are displayed 
as a numerical display in a window called the cockpit.

 

NOTE

 l The following functionality with the different manners of display is 
only available for the ServoOne.

These actual values can be displayed in various different ways. A right click in the 
window of the cockpit opens a context menu in which a further window can be 
opened using the menu item “Select instruments.” Setting or removing tick marks in 
the window specifies the type of display used for the individual instruments. Clicking 
outside of this menu or waiting 3 seconds while the mouse pointer is not located in 
this window closes it once again automatically.
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The possible types of display for each are either one numerical display (default) or 
two different analogue display instruments. Use the “Visible” checkbox to hide or 
show the desired displays.

 



Actual value groups

This function is not available for all devices!

A further possibility for displaying the actual values visually is the display window of 
the actual value groups. This can be opened using the project tree under ...> Device 
setting > Actual values > Actual value groups.

A selection of actual values is shown which is limited to five groups; positions, 
speeds, torques, voltages and temperatures.
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5.13  Messages
All of the sequences executed, operations and reactions of the system which take 
place during operation are logged in the “Messages” dialog box. This includes log 
entries, information, warnings and errors.

The “Messages" dialog box can be opened from the main menu under View > 
Messages.

Depending on the selection of the four message types, such as log entries, 
information, warnings and errors, these are displayed in the message window. 
Multiple selections are also possible. The sorting can be ascending or descending 
by number, date, message, object or position. The order is indicated by a small 
arrow in the respective sorted column.



The order of the columns can also be changed by selecting the fields “Date, 
Message, Object and Position” with the mouse.

The Message logger

To the left of the four message types there are three small icons for the management 
of the message logger. Use the folder icon to open the message logger.
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All messages are always entered in the message logger. The second icon is for 
deleting the entries in the message window.

The e-mail icon is for sending the message logger (Log file from xx.xx.201x...) to 
Helpline for troubleshooting or technical assistance.

When the message logger is opened, it appears in the main workspace of 
DriveManager 5 using a similar view to the message window, except that it contains 
two additional fields, “Filter text” and “Search” to facilitate finding special entries.

 



5.14  History of parameter changes in the device
All parameter changes are logged in the “History of parameter changes in the 
device” window. The parameter history can be opened from the main menu under 
View > History of parameter changes in the device.

The time of day, the old and new values of a parameter change, the subparameter 
name and the path are shown.
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Toolbar of the parameter history

Symbol Description

Clear entire history of parameter changes

Clear all undone changes from the list

Undo selected parameter changes

Redo selected parameter changes

Edit changed parameters: This function is used to once again find a 
parameter change whose location is no longer known. Once the line is 
selected, open the workspace with the desired subject area using the 
“Edit” button. If the parameter occurs in several subject areas, the 
“Select topic” window opens.

Start/stop the macro recorder: Activating the red "Record" button records 
parameter changes.

Pause the macro recorder. Activating the “Pause” button pauses the 
recording and it can be resumed by actuating it once again.

Play, opening a recording: Use the “Play” button to call up files. Clicking 
on the “Open” button transfers the saved parameter changes to the 
controller. (The parameter changes made are first effective in the 
project; once the project is online, the changes are also transferred to 
the connected device. If the project is offline, the parameter changes are 
only transferred once the project goes online again.)

Table 5.4:   Toolbar of the history of parameter changes in the device



Further functions and information on the macro recorder can be found in Section 
"Macro recorder" on page 38

 

Edit changed parameters:

Double-clicking on the line of the parameter change selects it and it is marked in 
blue. Once the line is selected, open the subject area in which the parameter is 

located using the “Edit” button .

If the parameter exists in several subject areas, then an additional window opens 
first in which the desired subject area can be selected. This window shows all of the 
subject areas which contain the parameter.
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5.15  Macro recorder
The macro recorder is for the specific recording and logging of parameter changes. It 
can be used to create batch files which contain defined parameter settings. For 
example, scope settings can be saved and transferred to another device. Before 
parameter configuration can be started, the macro recorder must be started and it 
then records all of the parameter changes. When the recorder is stopped, the 
settings are saved in a batch file. This means that the parameters continue to be 
available for further editing.

 Start/stop the macro recorder: Activating the red button (Record button) records 
all parameter changes. The following confirmation window appears.

 Recorder switched on (the blue square means that the recorder is activated)

 Stop the macro recorder. The Stop button stops the recording. This is followed 
by a prompt to save the data in a batch file.



 Activating the “Pause” button pauses the recording and it can be resumed by 
actuating it once again.

 Play: Actuating the arrow button plays back a previously recorded parameter 
change. When opening a recording (parameter, batch file.csv) with the “Play” button, 
csv files are called up. When doing so, a parameter change that has been made can 
be passed on to another device.

Clicking on the “Open” button transfers the saved parameter changes to the 
controller.
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Settings for the transfer of a recording

In order to transfer a batch file with the parameter settings, the setting “Always, 
including automatic sequences” must be enabled for the “Logging of parameter write 
accesses” under Extras > Options > Advanced functions.



5.16  Object search
The object search function in DriveManager 5 offers a convenient and simple search 
function which can be configured as desired. The search can be adapted to suit the 
requirements and preferences of the user.

 

Fig. 5.1: Object search and search results found
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The object search finds all parameters, help topics, help index entries and anything 
that can be associated with the search term. The quality and the areas searched can 
be modified using comprehensive setting options.

The “Settings” item offers an extensive selection menu for customizing the search 
functions.

This convenient settings dialog box allows precise definition of the object search. All 
of the option settings and search criteria are self explanatory.



Object search results

The hit list of searched for objects shows the results with the respective icons from 
the option menu.
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5.17  Invalid user input
After an invalid user or parameter input, a message window is displayed which 
directly indicates the incorrect input and shows the value range. After the window is 
closed, the input focus is again directed towards the object.



5.18  Blinking code 
The device display behaves differently depending on the device that is connected. 
Consequently all the information on the status messages of the LED display must be 
taken from the respective Device help.
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5.19  Printing documents
DriveManager 5 has a special print function with a variable print menu. Only the 
document which is the current focus of the workspace is printed. A document can be 
the list view of a subject area, an oscilloscope recording, a complete set of device 
settings in a list view or a data set comparison.



Page settings... / printer settings

The "Page settings...” menu item can be used to set up the print page to suit one’s 
own requirements. The settings always refer to the Windows default printer that has 
been specified.
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Print subject area (here, “Print encoder”)

When printing, the graphical view is never printed, but rather only the list view of the 
subject area in the current workspace. When doing so, the default Windows printer 
window appears in which the printer settings can also be modified.



Print preview (of the subject area)

The print preview offers the opportunity of viewing individual or all pages before 
printing. The settings do not refer to the printing, but only to the view.
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6  Projects

6.1  Project tree / Project window
The structure of a project is defined in the project tree. All devices or nodes are 
contained there, including all information files.

It contains the following nodes:

 n Project name

 n Network connection: USB or TCP/IP (depending on the device type)

 n IP address

 n Device name

 n Device setting

 n Digital oscilloscope

ID No.: 0842.05B.3-02   version: 06.2019 DriveManager 5   Program help 45

6  Projects

The project window with the project tree



The menu bar of the project tree allows a selection which defines to what level the 
existing nodes should be displayed.

The symbols + and - beside this allow a setting to be made as to whether all objects 
in the project tree should be displayed as open or closed.
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Different symbols are displayed in the upper menu bar of the project window, 
depending on the nodes and the levels. The right mouse button function selection 
corresponds exactly to this upper menu bar.



Project tree with three nodes, several devices in the network cluster

In the following project tree, three devices are connected via connection nodes in a 
network cluster under the IP addresses 192.168.39.5 to 192.168.39.7 in a single 
project.

The menu items shown below can be used to add additional devices or to remove 
existing devices. When doing so, a new window opens in each case to allow 
selection of new devices or of a device which is to be removed.
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6.2  Creating a new project

6.2.1  Create a new project when the program starts
When the program starts, the Project wizard opens by default.

Three points are then available: one to create a new project, and two options for 
opening an existing project.

ONLINE immediately, i.e. work with the connected device

 n Create a new project: In this case, all settings and data are automatically 
read from the connected device after the connection has been established 
and are used to set up a new project.

Work / start OFFLINE

 n Create a new project: In this case, the desired device can be selected offline 
via a selection of different device IDs (see below).

When creating a new project (online and offline), the “Define project” window opens.



Project name:

The new project must be given a name and this name is also used as the directory 
name for the project folder, meaning that only the alphanumeric characters typical 
for Windows and without *, ?, /, ", etc. must be used. All of the data which belongs to 
the project are saved in various different subdirectories.

Brief project description

A brief description of the project can be created as an aid to help find the project 
more quickly.
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Project folder:

The project folder is stored on a default path 
(C:\Users\Username\Documents\...\Projects), but it can be changed or reset once 
again at any time.

 

New project offline

With a new OFFLINE project, the “Add device offline” window opens.

Here, the desired device must be selected via the different types of device 
identification (device family, control hardware, power stage, axis, etc.).



There are also different types of communication connections available (TCP/IP, 
UDP, USB and USB COM), depending on the device family. The system suggests an 
IP address for connecting this device. The default address is: 192.168.39.5

Finally, the quantity of the same devices (with consecutive addressing) can be set as 
well.

Afterwards, the project tree for this device is created and the desktop of 
DriveManager 5 is loaded.

New project online

With a new ONLINE project, the “Select connection” window opens.

Here, as well, there are different types of communication connections available 
(TCP/IP, UDP, USB and USB COM), depending on the device family. The system 
suggests an IP address for connecting this device. The default address is: 
192.168.39.5

All internal device data and settings are then displayed in the project tree.

NOTE

 l A detailed description of the network communication connection 
can be found in the ServoOne CM device help under Contents > 
Device setting > Ethernet over EtherCAT® (EoE).
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6.2.2  Creating a new project from the desktop
There are numerous options for creating a new project from the DriveManager 5 
desktop:

 n Starting the Project wizard via the icon in the upper standard bar 

 n From the main menu: File > New > Project

 n From the main menu: Project > Project wizard

 n From the main menu: Project > New

 n Via the “New” symbol in the upper standard bar  > Project

 n From the main menu: Extras > Create device offline: Create a device offline 
using an existing description file (import of a ZIP archive or individual files)



6.3  Opening a project
An existing project can be opened in many ways:

 n From the main menu: File > Open > Project

 n From the main menu: Project > Open

 n From the main menu: File > Recent projects

 n From the main menu: File > Recent Files (selection of project files with the 
extension *.dmprj)

 n Using drag & drop: Use the mouse to drag project files with the extension 
*.dmprj to the first or second menu line of the DriveManager 5 user interface.

 n Double-click on a project file in Windows Explorer (desktop). The program 
starts and opens the project automatically.

 n Via the “Open file” symbol in the upper standard bar  > Open project

 n From the main menu: Extras > Options > Start/end program; the option 
“Action on program start" can be used to specify that the last project should 
be opened automatically, with or without a prior query.
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 n And, of course, from the Project wizard 

 
Here, an existing project can be opened as can one of the recently edited 
projects.

When opening a project, one of the most recently edited projects can be opened in 
the “Select project” window or the “Others” button can be used to jump to a Windows 
file dialog for the selection of another project file.



6.4  Saving a project
An existing project can be saved in many ways:

 n From the main menu: Project > Save project “ProjectName”: Saves the 
current version of the open project.

 n From the main menu: Project > Save project “ProjectName” as ...: Saves the 
current version of the open project, but at a different storage location or as a 
copy of the project under a new name.

 n From the main menu: Project > Close project “ProjectName”: A query follows 
as to whether the project should be saved.

 n When the program is closed, there is also a query as to whether the current 
project should be saved. General settings for this can be found in the main 
menu > Extras > Options > Program start and end under “On program 
closing."
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6.5  Deleting a project
All projects are saved in project folders which have the same name as the project 
itself. All of the data which belongs to the project are saved in various different 
subdirectories. To delete the project, the entire folder must be deleted in Windows 
Explorer, including the project file *.dmprj.

This folder can be found in the main menu under the Extras menu item in the 
Options window.



6.6  Freeze and reactivate project
For archiving projects, it is possible to save a project in the "FrozenProjects" folder 
using the command “Freeze current project.”

Start from the main menu under the menu item Project > Management > Freeze 
current project

The file “ProjectName".dmprj_archive is then archived here and thus the project is 
closed. The archive file still remains available after the project and the project folder 
is deleted.

The call for reactivating a project from the "FrozenProjects" folder can be made 
using the command “Reactivate project."
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Storage location for archived projects (Frozen Projects) in the 
DriveManager 5  folder:

The frozen projects are saved under "FrozenProjects" and are not in the project 
folder.

NOTE

 l Freezing a project not only creates an archive, it also removes the 
project from the list of active projects, i.e. it deletes the entire 
project directory under “My files\...Projects.” On the next “Open 
project,” this project will then no longer appear in the list of 
selectable projects. If the project is then reactivated, the project 
directory is created once again.



6.7  Project archive
One purpose of a project archive is to save all the information and settings which are 
part of a project in a single file so that it can be sent via email, for example, for 
service purposes. This also provides a simple means of project management. For 
versioning purposes, different project states can be archived and reactivated as 
needed.

Accordingly, a project archive contains all project data with all device settings, the 
project tree, scope recordings, commissioning files, logs, protocols, error files, etc. of 
the project folder grouped together in a compact and compressed file. 
The file extension is: *.dmprj_archive

Extracting, saving or sending a project archive:
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Extracting an archive (loading)

The selected project archive is loaded as a project. If there is already a project with 
this name, the imported project is renamed so that no name conflicts occur.

Save current project as archive ...

A project archive file is created (zipped) and is saved under the selected path in 
compressed form as “<ProjectName>.dmprj_archive”. If there is already a project 
with this name, the created project is renamed so that here as well no name conflicts 
occur.

Send current project as archive

An existing project folder is put into one project archive file named 
“<ProjectName>.dmprj_archive" (zipped) and is added to an email as an attachment. 
This allows a data exchange to be carried out easily. See Section "Email function" 
on page 58



6.8  Send project
One purpose of a project archive is to save all the information and settings which are 
part of a project in a single file so that it can be sent via email, for example, for 
service purposes.

Accordingly, a project archive contains all project data with all device settings, the 
project tree, scope recordings, commissioning files, logs, protocols, error files, etc. of 
the project folder grouped together in a compact and compressed file. 
The file extension is: *.dmprj_archive

Send current project as archive

An existing project folder is put into one project archive file “<ProjectName>.dmprj_
archive" and is added to an email as an attachment. This allows a data exchange to 
be carried out easily.
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If, for example, Microsoft Outlook is installed as the email program, an email form 
with attachments can be created with no extra steps performed by the user.

This email contains the following text lines, among other things:

*** Project ***
Name: >ProjectName<
Introduction: >BriefDescription<
DriveManager 5 message from DAY, xx.xx.2017 TIME
User: >Username<
Machine: >ComputerName<
Operating system: Microsoft Windows xxx
DriveManager 5 Version: 5.x.x.x

List of currently installed plug-ins:
Kernel: Version, Release 
ClineKernel: Version, Release 
Magnetic-Bearing: Version, Release 
...

The recipient of the email can install a project archive directly by double-clicking the 
attachment or can open a zipped message logger.

For additional information on the email function, see Section "Email function" on 
page 58



6.9  Functions for all devices in the project
In a project, there are functions which can also be carried out simultaneously for all 
devices. The functions for which this applies can be found under Project > All 
devices and are shown below:

 n Save setting persistently inside device

 n Quit error

 n Restart...

 n Reset to factory settings

 n Load device commissioning file...

The advantage of these functions under “All devices” is that each item can be carried 
out the same for all devices in the project. For example, when “Load device 
commissioning file...” is selected, the same commissioning file is sent to all devices 
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in the project at the same time, which provides not only convenience, but also 
significant time savings, provided there is a good communication connection. All of 
the submenus are also available for individual devices.

NOTE

 l The “All devices” menu item and these functions in general are 
only enabled ONLINE. In OFFLINE mode, this menu item is 
disabled.

 



7  Manual mode window
The manual mode window allows a drive to be controlled independently of a higher-
order controller. The drive can be operated in every control mode using the 
individual dialog boxes of the window.

After the manual mode window is opened, a view corresponding to the control mode 
opens. To execute a movement of the axis, the hardware enable must first be 
activated and the safety notice must be confirmed.

The following control modes are available:

 n Position control mode "PCON"

 n Speed control mode "SCON"

 n Torque control mode “TCON"

 n V/f control mode "VfCON"

The “Manual mode” window is then active so that the control mode can be selected 
and the parameters configured for the manual mode. Depending on the control 
mode you selected, various different tabs will appear:

 n A tab with the parameters that are specific to the respective control mode but 
that only apply when the manual mode is used (e.g. acceleration, 
deceleration, setpoint, speed, etc.)

 n Homing (see section “Homing / homing mode” in the device help)

 n Jog mode, which can be used to move the motor step-by-step in a positive or 
negative direction with two different speeds.

 n Reversing mode, in which the motor can be moved back and forth with 
adjustable accelerations and speeds.
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Fig. 7.1: Examples of an active manual mode window

After the manual mode window is closed, the original device settings are restored 
automatically.

NOTE

 l The description of the individual control modes with their specific 
parameters for the manual mode, such as acceleration, 
deceleration, setpoint, speed, but also the different homing 
methods, etc., can be found in the corresponding device help.
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8  Email function
The email function allows an easy means of exchanging data.

 n Entire projects can be sent via email from the main menu under Project > 
Project archive > Send project as archive (Also see the section “Sending 
projects” on this topic) The recipient of the mail can install a project archive 
directly by double-clicking the attachment or can open a zipped message 
logger.

 n The DriveManager 5 message window also allows log entries, information, 

warnings and error messages to be sent via the email function .

 n Error messages can also be sent directly from the error window.

If Microsoft Outlook is installed as the email program, an email with attachments can 
be created with no extra steps performed by the user.

For users who do not have MS Outlook, prior configuration including specification of 
the connection data allows emails to be sent directly by DriveManager 5.
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Configuration of the Email support

The respective fields under Extras > Options > Email support in the main menu must 
be activated and filled in.

Fig. 8.1: Activated email support for MS Outlook

Here, a signature and an additional address for the activated “cc:” function can be 
configured. There is also a sample text available for the signature. 
Because some Internet providers only permit emails up to a certain size or, for 
example, in-house company email limitations could apply, there is an option here 
which generates a warning message for emails which are of greater size: 
“Obtain confirmation for sending if attachment size exceeds" the preset "12 MB". 
The size for the messaging can be changed here. If the content of the email to be 
generated then exceeds the limit entered and if oversize is also confirmed by the 
user, then “less important” parts are automatically omitted as the email is generated.



The email is only prepared by DriveManager 5, including attachments. Users can 
expand on the preset text themselves and must then send the message themselves; 
this does not take place automatically.

If a different email program is used, like Mozilla Thunderbird, Opera Mail, Google 
Mail, etc., then the selection must be changed to “Send email directly". The name or 
the IP address of your SMTP server will be needed for this as well as your email 
address. The exact type of access for your SMTP server is important here, whether 
via Intranet or Internet (access data is required). Please contact your in-house 
company IT support with questions concerning setup.

Fig. 8.2: Direct email sending without MS Outlook using an SMTP server

 

Sending exception messages directly from the error window
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Fig. 8.3: Sending an error message via email directly from an error message window

Once an error is displayed in an error window as an “exception message”, there is 
also the option of automatically generating an email with the error description, the 
project and the message logger.

 



Sending an email directly from the project window

As shown in the following figure, there is still another possibility for generating an 
email automatically. The email button in the icon list of the project window is usually 
hidden. When these hidden icons are displayed, the email function also appears.

Fig. 8.4: Email sending directly from the project window

 

Sending an email from the help information window

There is also an option for generating an email in the main menu under “Help > 
Information” under the view of all installed plug-ins (under Details). This contains 
only system information and the list of the currently installed plug-ins.
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9  Drive status

9.1  Device status window (Device status)
The “Device status” dialog box provides an overview of the current state of the 
system. This should generally always be open so that any possible faults can be 
recognized visually at once. In the event of a fault, the colour of the button changes 
from green to red. A maximum of 20 error messages can be logged via the "Error 
history" button. Once the memory is full, the oldest error is overwritten.

Depending on the device that is connected, you are shown the corresponding 
device status window for the drive containing different status information and the 
system state.
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Fig. 9.1: Example images for different devices

Status messages are divided into axis status messages and device status 
messages and can be opened via the corresponding buttons directly on the quick 
start bar.

   

 l Further information on this can be found in the Device help in the 
“Status” chapter.



9.2  Faults/Alarms/Warnings
Faults are displayed in the ‘Device status’ dialog box or by means of a red field. In 
the event of an error, the pop-up window “A device error has occurred” opens.

The “Error history” button is located in the upper section of the device status window. 
The last 20 errors can be viewed here. This opens the “Alarm History/Warning" 
window:

Fig. 9.2: “Alarm History/Warning” window

A detailed history of the last 20 errors can be displayed in the project window directly 
in the project tree under ►Axis adjustment ►Device ►Alarms / Warnings.
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This screen includes:

 n Causes

 n Troubleshooting tips

 n Buttons for quick access to the defined error reactions and warning 
thresholds for device and axes

 n Warning status display for every axis

 

 l A list of the possible error codes can be found in the application 
manual of the respective device in the section “Diagnostics”.

 l The complete error list is also contained in the Device help (under 
Alarms/Warnings ►Error list). A good deal of further information 
on warnings, error reactions, the error history and error simulation 
can be found here.



9.3  Error messages/Error display
An error which is due to the operating software and not a device appears in the 
“Error message” window.

“Error message” window

“Error message": Description of the error that has occurred

"Further information": Additional information or error descriptions

“Error object": Information on the error location

“Acknowledge": Resets an error message

“Disconnect": The connection to the connected device is terminated.

“Establish new connection": An interrupted connection is reestablished.

“Close document in which the error occurred": The operating software remains 
"online” once a defective document has been closed.
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Procedure in the event of an error:

 n “Close program": The program must be closed when a fatal error has 
occurred.

 n “Close current dialog box": If the error occurs within a dialog box, the dialog 
box is closed. Work may be continued with the operating software.

 n “Close project": If the error is so fatal that the project is no longer functional, 
then the project is closed. 

 n “Close all windows": If the error which has occurred affects too many 
windows, it makes sense to close all documents. It is still possible to continue 
working with DriveManager 5, however. After the error has been remedied, 
the windows can be opened again, one after the other.

 n “Remove device from project": In a project with several nodes, it can be 
useful to remove a fault device from the project so that work can be continued 
with the remaining devices.



10  Device settings

10.1  Save/Load/Transfer device settings

10.1.1  General
There are various different ways and different objectives which are decisive for 
saving or loading. Depending on the active device, parameter data sets, device 
settings, device commissioning files, settings for an axis or the motor data of an axis 
can be created, saved and transferred.

These functions can be called in a number of different ways:

 1. Via the tool bar “Basic operations of the active device”

 2. Via the main menu under “Active device / Active axis”
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 3. Or via the project tree under the device node.

The pictograms indicated in the table show which icon is required for which saving 
or loading function.



Key to pictograms

Symbol Description

Save current device setting to file: Actuating this button opens a 
window in which a selection must be made as to whether a 
parameter data set or a device commissioning file should be 
saved.

Transfer device setting from file to device: The device setting is 
loaded from a file and transferred to a device.

Load data from axis and save to file: Here, the settings of an 
axis or the motor data of an axis are saved.

Copy data from file to the axis: The settings of an axis or the 
motor data of an axis are transferred from a file.

Save settings persistently in device (RAM to ROM): The device 
settings are saved in the non-volatile memory (ROM) of the 
device.

Create device commissioning file: Create commissioning file for 
the active device or for the entire project.

Load device commissioning file:

Table 10.1:   Key to pictograms
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There are different file extensions depending on the type of data:

 n Parameter data set and partial files for the device commissioning: *.dmdvadj

 n Firmware package file: *.comfwarc

 n Firmware files: *.hex

 n Device commissioning files: *.comdvarc

 n Device commissioning files: *.tftpcom (only for SO CM, TFTP (Trivial File 
Transfer Protocol) for simple file transfer without a loader program, or 
DriveManager 5)

 n Project commissioning files: *.comprjarc

 n Settings for one axis (*.dmaxdataset)

 n Motor data for one axis (*.dmaxmotdat)

 n iPLC  files (*.plc)

The respective storage location can be changed via the main menu under "Extras > 
Options > Documents".

 

10.1.2  Save current device settings in file

 Actuating this button opens an introductory information window in which 
a selection must be made as to whether only a parameter data set or a device 
commissioning file should be saved.



When Save as parameter data set is selected, a window opens for saving the 
device settings using the file type *.dmdvadj.

Afterwards, the creator and a description can be supplied in an additional window. 
The Options button opens yet another window for the exact selection of parameters 
(All those portable / Only motor data / Select storage group(s) / Select individual 
parameters).
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Save as device commissioning file

A window opens here independently of the connected device in which the exact 
contents of this file must first be defined. The contents are always dependent on the 
active device and consist of at least two sources which must be defined.

1. Selection of the source for the firmware package: *.comfwarc

2. Selection of the source for the device setting (parameter data set). However, there 
are three options here.

 n Device

 n File: Partial files for the device commissioning: *.dmdvadj

 n Restoration from target device: Here the original data of the target device are 
written back after loading of the firmware package.



Here it is also possible to add different types of information and descriptions before 
the save operation. Afterwards, the window for saving the device commissioning file 
opens (*.comdvarc).
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10.1.3  Transfer device setting from file to device

 This is the reverse method; loading the device 
settings “FileName".dmdvadj and transferring to the device. Additional windows with 
information and options open for this purpose. A log of the copy operation can also 
be displayed.

 



10.1.4  Load data from axis and save to file
This option is only available for devices of the series SO CM.

 Actuating this button opens a window in which the data type to be saved 
can be selected:

 n Settings for one axis (*.dmaxdataset)

 n Motor data for one axis (*.dmaxmotdat)
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Afterwards, an additional window opens containing the following selection:

 n All axis settings

 n Axis motor data only

The creator and a description of the file can also be entered here.

 

10.1.5  Copy data from a file to the axis

 Actuating this button opens a window in which the data type to be loaded 
can be selected:

 n Settings for one axis (*.dmaxdataset)

 n Motor data for one axis (*.dmaxmotdat)



Afterwards the following control window opens. Here, a log of the copy operation is 
displayed while the data are being copied.
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10.1.6  Create device commissioning file

 In the first step, the extent and the contents the device commissioning file 
should have must be selected.

 n File for commissioning the entire project

 n File for commissioning only the active device

Afterwards, a window opens in which the exact contents of this file must first be 
defined. The contents are always dependent on the active device and consist of at 
least two sources which must be defined.

This process has already been described in Section "Save as device commissioning 
file" on page 66

 



10.1.7  Load device commissioning file

 This pictogram is used for loading a device commissioning file.

This is the reverse method; loading the device commissioning 
file “FileName".comdvarc and transferring to the device.

Further information about the entire topic can be found in the section: Serial 
commissioning Introduction

The macro recorder can also be used to create, save and transfer individual 
parameters. Further information about this can be found in the section: Macro 
recorder.
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10.2  Printing the device setting
The device setting can be printed in part or as a complete parameter list in the list 
view.

Only the parameters of the dialog box which are focused in the workspace are 
printed when the print command in the main menu under File > Print device setting 
is used. Using the subject area “Overview” icon prints all device settings which can 
be accessed in the “Local administrator” user level.

The subject area to be printed or the overview of the device setting must be the 
present focus of the workspace.

Further information about printing can be found in Section "Printing documents" on 
page 42.



10.3  Compare data sets and settings
The current device settings can be compared with an previously existing data set, 
with a data set of a different device or with the factory settings.

  Compare settings

Click on the "Compare settings" icon in the standard bar or on this menu item in the 
main menu under Extras > Compare settings.

Choose the two data sets which are to be compared. In addition, the selection of the 
parameters can be restricted further and whether the parameters which are not 
present should be marked can be specified. Start the comparison by actuating the 
button.
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The two data sets are contrasted in the dialog box displayed for the parameter 
comparison:

The view can be printed out using the print command in the main menu. There is 
also a print preview available.With a right-click on the dialog box of the displayed 
data sets, this can also be saved as a data set.
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11  Digital oscilloscope/digital scope

11.1  Scope settings

11.1.1  Basic functions of the digital oscilloscope
Using the digital oscilloscope makes it possible to record time histories for control 
variables as well as individual bits of control and status words. There are 6 channels 
available for this purpose. This is a suitable tool for commissioning, analysing 
controller performance and for error analysis.

Functions and settings

 n Recording with up to 6 channels.

 n Trigger signal selection

 n Pre-trigger selection

 n Bit-trigger selection

 n Time basis selection

 n Editing recordings

 n Creating serial recordings

 n Save, load and archive 

11.1.2  Operating the digital oscilloscope

The oscilloscope in the window view:
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Operating the digital oscilloscope is typically done via the "Digital Oscilloscope” 
window. All of the functions are available in one window with different tabs. It can be 
positioned as desired, hidden or undocked or also be anchored at the edge of the 
screen as a tab.

 

Functions available via the “Central Oscilloscope Control":

Another option is to use the “Central Oscilloscope Control”. This can be opened via 
the main menu under Project > Central Oscilloscope Control in the central active 
window. Here there are separate windows for all of the channel, trigger signal and 
time settings and these have the same parameters as in the oscilloscope window.



 

11.1.3  The channel selection
The digital oscilloscope window contains four tabs with different displays for 
channel, trigger, time and options. The first (left) tab contains the settings and 
functions for the “channels” of the oscilloscope. The buttons with the digits 0 to 5 
indicate the available channels. A single click on the rectangle opens the editor with 
the available recording variables for this selected channel.
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Channel selection and configuration

The channel selection window opens the window for the signal selection. However, 
this can also be opened directly from the project tree under > Digital oscilloscope > 
Signals.



 

Direct visualization of the signal in the subject area

If a subject area has signals, a new node with the name “Scope signals of ...” is 
created under this subject area. The signal selection window opens when this node 
is activated. The window can be closed using the “x” button (The window only closes 
automatically if it was opened in a screen with the cursor on an arrow or the green 
signal curve)
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The signal window with the currently contained signals for the respective subject 
areas/topics can be opened everywhere the oscilloscope pictogram or the blue text 
“Oscilloscope signals of” appears.

Displaying the signal selection in a graphic interface dialog

 



Description of the signal selection window
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Column Description

ID Display of the parameter number with the ID of a parameter signal.

Index Index number (subparameter)

T P: Parameter signal / S: original signal

Channel Channel selection: Off, channel 0-5 and trigger

Signal Signal description /Signal name

Unit Parameter variable unit

Symbol Symbol name

Type Data type (Unit, Float, Bool, String, ...)

Table 11.1:   Description of the signal selection window symbols

 



Display raw device data (expert mode)

When the option "Display raw device data” is enabled, invisible parameters which 
might exist in the background are displayed (main menu: Extras > Options > Display 
> Display of device data).

After a reboot of DriveManager 5, the raw data of the device are then visible once 
the “Display raw data" button is enabled.
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11.1.4  The trigger settings
The settings for triggering can be found in the digital oscilloscope window on the 
"Trigger" tab. The event that is to trigger the recording can be defined here.

The “Manual Trigger" button initiates the event which triggers a recording with a 
single mouse click.

The trigger mode can be set in the pull-down menu under “Mode", which means the 
trigger edge can be selected. The trigger signal can be sent on a rising or falling 
edge or by both edges, either normally or symmetrically.

The "Level" setting specifies the signal level, or threshold, at which the recording is 
triggered.

With the "Pre-Trigger" function, the recording begins before the actual trigger point, 
e.g. 10% relative to the recording duration.

“Bit Trigger”: Triggering starts when a selected bit of the DRIVECOM state machine 
has been set. Range [-1...31] (For information on the DRIVECOM state machine > 
see Device help)



11.1.5  The time setting
The recording duration and the sampling time can be set in the digital oscilloscope 
window on the “Time” tab. Values smaller than the base sampling time are ignored 
and are set to the respective value of the base sampling time. The sampling time is 
limited by the available storage capacity for the scope function and the number of 
active channels. The recording duration entered by the user is reset to reflect an 
optimized value based on these criteria.
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Setting the time basis

NOTE

To achieve the best resolution, it is recommended that the “sampling 
time” be set to 0 and then the desired recording duration be selected.

11.1.6  Options
In the digital oscilloscope window on the “Options” tab, a container name can be 
selected in which the subsequent recordings are saved. If a series recording is 
desired, this function can be set by placing a tick mark beside “Enable serial plot.” 
After a recording has been made, it is loaded to the container specified for this 
purpose. If no container name is specified under “Container,” a name with a 
timestamp is generated automatically. The desired recording time can be selected 
from between 0% and 100% of the maximum possible recording time.

Assigning a container name:



 n Set container to “new.”

 n Permit serial recordings (only if desired)

 n Assign a defined container name

 n Optional: "Always create a new container” for every recording

The “Activate Oscilloscope" button makes it possible to activate the oscilloscope in a 
servo controller via DriveManager 5 and subsequently terminate the connection 
again. If a trigger event occurs after the disconnection, this can be displayed via the 
“Read oscilloscope data” button after the connection has been re-established.
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11.1.7  Start recording
If the oscilloscope is not visible in the user interface, it can be opened in the main 

menu under “Active device” using the symbol  Digital Scope or via the project 
tree “Digital Scope”.

Procedure for a recording:

 1. Channel setting: Select the variables to be recorded. Select display of the 
labelling on the right or left y-axis

 2. Trigger setting: Select the trigger signal and set the trigger conditions

 3. Time setting: Enter the sampling time and the recording time

 4. Triggering a recording: 
Actuate the button "Start". When the trigger conditions are fulfilled, the 
recording begins automatically. A recording can also be started manually. To 
stop a recording operation prematurely, actuate the "Stop" button. The 
"Status" display shows the current state of the digital oscilloscope.



11.2  Scope recording
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11.2.1  Toolbar for editing oscilloscope recordings



Symbol Description

Visual signal setting / Curve display:

 n Selection of the scope variable to be edited

 n Switch signal view on/off

 n Arrangement of the Y variable on the left or right Y-axis

 n Curve display: Colour, line thickness

 n Measurement values can be indicated with an accuracy of up 
to 6 decimal places
See Section "Visual signal setting / Curve display (signal 
properties)" on page 85

Edit record caption: Edit the title of the scope recording.

Table 11.2:   Symbols on the toolbar for editing oscilloscope recordings
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Symbol Description

Comment/Information: Dialog box for entering a comment. The 
comment is displayed as soon as the mouse is moved over this 
button. The comment cannot be printed.

Zoom plot: Enlarge/reduce the size of an image detail. The area to be 
zoomed can be pulled open with the left mouse button held down.

Move plot: Move a scope recording

Scale plot: The entire recording can be enlarged or made smaller 
with the left mouse button held down.

Original size: Restore to the original size



Symbol Description

Switch display on/off for title, footer and key: This allows the title, 
footer and key to be shown or hidden.

Activates measurement tool: Measure the curves; measurement 
values can be read in the measurement value window. See Section 
"The measurement tool" on page 85

Activates/deactivates ‘dragging' and ‘dropping': 
Activates/deactivates ‘dragging' and ‘dropping' for curves, which 
makes cutting, copying and saving them possible. See Section "Cut, 
Copy, Paste and Save" on page 83

Mathematical functions: FFT, Subtraction, complex FFT, addition, 
frequency analysis. See Section "Mathematical functions" on page 86

Activate setting of the oscilloscope on the device: Oscilloscope 
settings from a recording are applied directly by actuating the button 
and the original recording conditions are thereby restored.

Conversion of the recording to an Excel file: The coordinates of a 
recording are transferred to an Excel list and saved.

Oscilloscope help: Opens the online program help

Show numbers in hexadecimal: Switches the numbers between 
decimal and hexadecimal

Table 11.2:   Symbols on the toolbar for editing oscilloscope recordings (continue)
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Symbol Description

Axis assignment for direct measurement: Selection of the left or 
right Y-axis

Display of the measured values

Add digital oscilloscope recordings: Add additional recordings to 
the open container.

Delete digital oscilloscope recordings: Delete recordings from the 
container and also from the hard drive.

Divides the container into two views: Opens a second container. This 
means these scope recordings can be displayed next to each other 
(using a new horizontal or vertical tab group).

Send digital scope recording via email: If Microsoft Outlook is 
installed as the email program, an email with attachments can be 
created with no extra steps performed by the user (see Section "Email 
function" on page 58).

Table 11.2:   Symbols on the toolbar for editing oscilloscope recordings (continue)

11.2.2  Saving a recording
Generally, all recordings are saved automatically; no explicit saving is possible.

“Save as”

The currently open recording is saved under a new name.

The saved recording is stored on the path C:\Documents and Settings\User 
Name\My Files\DriveManager 5\Projects\Demo_Project\Digital Scope with the 
extension: xxx.dmdsr. The storage location can be changed under Menu <Extras 
<Options.



11.2.3  Loading an oscilloscope recording
A saved scope recording (*.dmdsr) can be loaded via the main menu under ‘File > 
Open > Oscilloscope recordings...’.

 

11.2.4  Cut, Copy, Paste and Save

 

Individual curves within a graphic can be selected, copied, cut and pasted into a 
different graphic. A recording can be saved in the BMP, JPG or TIF format under 
Save image as.... A selected curve is displayed with a double-wide line width. The 
function can be cancelled by clicking in the area next to a curve. 
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The selected curve can be copied to memory using the Copy function and the 
marking of the currently selected curve is removed. With a right-click in a second 
graphic, the options menu is once again displayed at the top in the centre of the 
image. In this case, the functions “Cut” and “Copy” are disabled and the function 
“Paste” is enabled. Selecting this function inserts a copy of the previously selected 
curve from the first graphic into the second graphic. The scaling is adapted 
automatically and the inserted curve is shown in a different colour. Use Cut in the 
same manner with the exception that the curve selected in the first graphic is then 
deleted.
A curve can be copied from one graphic to another with the “drag & drop” function. 
To do so, after the curve has been selected, press and hold the <Ctrl> key and then 
left-click the curve and hold down the mouse button while dragging the curve into 
the second graphic. The cursor changes to an arrow with a plus sign.



11.2.5  Labelling a scope recording

 

Any name desired can be chosen for the scope recording. The default designation 
consists of the label “Recording of device, date and time” as the title of the graphic.

11.2.6  Print an oscilloscope recording
DriveManager 5 has a special print function with a variable print menu. Only the 
document which is the current focus of the workspace is printed.

If there is only one recording, the print command in the main menu under File > ... 
Print prints it out.

If there are several recordings available in a container, the one that is currently 
visible is always the one that will be printed. The recording can be printed in portrait 
or landscape format. If the measuring tool is active, the measurement values are 
also printed out. A print preview can also be displayed.
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Additional information on the general print functions can be found in the Section 
"Printing documents" on page 42



11.2.7  Visual signal setting / Curve display (signal prop-
erties)

The display of a curve can be modified as desired. Select the curve which is to be 
modified using the “Visible signal properties” window. Curves that are not needed 
can be hidden completely.
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Procedure for curve display:

 n Selection of the recording variable to be edited

 n Show/hide signal view: Curves can be shown or hidden.

 n Arrangement of the Y variable: In order to get an optimal display of the curve, 
the coordinates of the y-axis can be displayed either on the left or the right y-
axis.

 n Curve display: Modifying the colour and line thickness

 n Decimal places: The decimal places refer to the "Measurement tools” 
function. Measurement values can be specified with an accuracy of up to 6 
decimal places.

11.2.8  The measurement tool

The tool for measuring function curves can be activated using this pictogram or with 
this button in the toolbar. The measurement function remains active after use and 
actuating it once again then disables the function.

Using the measurement tool

The red markers are labelled with T1 and T2 on the x-axis (abscissa) and with S1 
and S2 on the y-axis (ordinate). To the left, next to the marker of the ordinate, there 
are two fields which indicate the exact position of these markers on the ordinate.

Two additional red markers on the right side, marked with S1 and S2, serve as 
additional measuring sensors with exact position and magnitude information.

The measured values are displayed in the lower area of the window (markers T1/T2, 
difference between the two markers, RMS, mean value, etc.)
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Moving the markers:

 1. Click the red triangular areas and with the mouse button held down, move to 
the left or right or up or down.

 2. Click any location. The pair of markers "T1" and "S1" must be moved so that 
the intersection point of these two markers is located at the point which was 
clicked. If the <Ctrl> button is also held down when clicking, the two markers, 
T2 and S2, are moved. 

Once markers T1 and T2 have been moved to the location that is to be measured, 
the values are displayed below. The window contains the designation of the 
recorded curve, its units and the values at the T1 or T2 position, the difference 
between these two values, as well as additional data. There are checkboxes located 
at the left side with which the individual curves can be set to be visible or invisible. 
If the accuracy provided by 3 decimal places is inadequate, it can be increased to a 
maximum of 6 places in the “Signal properties” dialog box. 

If the number of curves to be displayed in the measurement value window exceeds 
the space available in the window, scroll bars are automatically added, with which 
the areas that are not visible can be displayed.

11.2.9  Mathematical functions

 

Various different computational operations can be carried out using the 
mathematical functions.



11.2.9.1  Addition and subtraction

Two curves can be added or a second curve can be subtracted from a recorded 
curve. Please note here that both curves must be from the same oscilloscope 
recording. Curves with different sampling times cannot be added together.
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11.2.9.2  FFT (Fast Fourier Transformation)

A Fast Fourier Transformation of a signal is calculated. The result is the value of the 
amount and the phase.

This function serves to specify the frequency spectrum of any time signal desired, 
which can then be selected as "Operand A" after this option has been selected. 
Overall, all time signals of the selected scope recording are available. Compliance 
with the sampling theorem must be ensured by the user already at the point in time 
of the recording. Before actuating the “Apply” button, the user is able to make further, 
optional fine-tuning settings in the “Expert mode” which then affect the FFT that is to 
be carried out.

 



11.2.9.3  Complex FFT (complex Fast Fourier Transformation)

A complex Fast Fourier Transformation of a signal is calculated. The result is the 
absolute value of the amount and the phase.

The complex signal is entered in operand A (cosine signal real part) and operand B 
(sinus signal imaginary part). The FFT is formed using these two signals. The result 
is an estimate of the unbalance of the two encoder signals of a sin/cos encoder in 
terms of amplitude and phase. The advanced dialog box screen allows the 
elimination of the average value of the time signal as well as formatting of the axes. It 
is possible to switch between a linear and a logarithmic display.

 

11.2.9.4  Bode plot

The Bode plot serves as a visualization of the transmission behaviour of a dynamic 
system and is also called the frequency response. An analysis of the quotient of an 
input signal and an output signal is calculated.
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The “Bode Plot” option serves as a tool for signal analysis in the frequency range 
with which the transfer function between any two measurement signals can be 
determined. This makes it possible to create a model of a mechanical drive train for 
the design of the control system. Two time signals must be selected as operands A 
and B. Here, operand A is the excitation signal measured at the system input. 
Operand B must be set to the measured system response. Because of the finite data 
volume which results from the finite recording duration, only a frequency response 
estimate is made. After a computation of the frequency analysis, the amount and the 
phase are displayed in two containers.

 



Explanation of the parameters and the enhanced parameters of the 
mathematical function

Depending on the selected mathematical function, the dialog box may differ from 
that shown. Some parameters are not available in every mathematical function.

Apply: The mathematical operation is carried out. The dialog box remains open. 
Further calculations are possible without needing to reopen the dialog box.

Close: The dialog box is closed.

Reduced: The dialog box can be displayed in the reduced form or in the expanded 
form with additional parameters. This option is not available for all mathematical 
functions.

Window type: Selection of various different window functions. Without the window 
function, strong signal peaks can occur.

Frequency: Type of frequency analysis

H0 – During the calculation, no forms of interference are suppressed which occur 
due to inadequacies in the measurement of the input and output signals.

H1 – Interference of the output signal is suppressed.

H2 – Interference of the input signal is suppressed.

Value range: Specification of the lower and upper limit of the frequency to be 
displayed.

Remove mean value: This parameter removes the mean value or the linear 
deviation of the data in four different ways: 'none': The mean value is not removed. 
'short': Removes the mean value from every data segment. 'linear': Removes the 
calculated linear deviation from every data segment. 'long-mean': Removes the 
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mean value from the data before they are subdivided into segments. If the mean 
value is not removed from the data, then there is a large signal peak at a frequency 
of 0 Hz.

Length of the FFT: This parameter makes it possible to set the length of the Fast 
Fourier Transformation. The value is set to the length of the window by default. If a 
value larger than the length of the window is set, all excess values are filled in with 
zeros. If a smaller value is set, the window length is ignored.

Window length: This parameter provides the option of setting the length of each 
data segment. This value is set by default to window = sqrt(length(x)) and it is 
rounded up to the next power of two and is filled in with zeros.

Amount (x-log / y-log): In the results window, the absolute value can be displayed 
logarithmically in the abscissa (X-axis) or ordinate (Y-axis).

Phase (x-log / y-log): In the results window, the phase can be displayed 
logarithmically in the abscissa (X-axis) or ordinate (Y-axis).

11.2.10  Container functions

11.2.10.1  Container

You can fill a container with numerous recordings. When a container with the 
extension "*.dmdsc" (old) is opened with DriveManager 5, a directory with the same 
name is created automatically and the recordings which belong to the container are 
copied to this directory.

There can be any number of recordings saved in a container. Please take note, 
however, that only a maximum of 10 recordings can be present in the memory. 
Additional recordings are loaded separately as needed. If a container with 30 
recordings in opened, for example, the selected recording and the 4 previous as 
well as the 5 subsequent recordings are loading into the memory. When a recording 
which is located outside the range of the 10 recordings already located in the 



memory is selected in the selection combo box, a message box and a progress bar 
indicate that additional recordings are being loaded. 
Moreover, please note that any modification of a recording such as the designation 
of a recording, changing the colour of a signal, copying a signal from a different 
recording immediately results in the recording being saved. This means that the 
recordings stored on the hard drive are always up to date. This also means that the 
“Save” icon in the toolbar and the “Save” menu item in the “File” menu are disabled. 

No explicit saving of a container or a recording is necessary because the current 
state is saved automatically. The option of saving with another name using “Save 
as...” is still possible. A dialog box opens in which an existing directory or a new one 
can be selected. When making an oscilloscope recording, you can select in which 
“Container” the recording should be recorded. To do so, a container name must be 
selected.

Assigning a container name:

 1. In the oscilloscope window, click on Options

 2. Assign defined container name

 3. Enable or permit serial recordings (only if desired)

 4. Activate start button

ID No.: 0842.05B.3-02   version: 06.2019 DriveManager 5   Program help 90

11  Digital oscilloscope/digital scope

Contents of a container

After a recording has been made, it is loaded to the container specified for this 
purpose. If no container name is specified, every recording is automatically given a 
current time stamp. All of the recordings are located in the selection field (see figure 
below). The button with a green arrow becomes visible if there are at least two 
recordings in the container. The arrows are used to navigate to the desired 
recording. The middle button starts a slide show of the recordings.

If there are one or more recordings in a container, the “Save image as” selection 
field can be opened with the right mouse button. A recording can then be saved in 
the bmp, jpg or tif format.

11.2.10.2  Serial recording

Use the “Options" tab in the digital oscilloscope dialog box to create serial 
recordings. The serial recordings are saved in a single container. As an option, each 
individual recording can have its own container name assigned. The serial 
recording can be started using the "Start" button.

24 hours Recording



The “Activate Oscilloscope" button makes it possible to activate the oscilloscope in a 
servo controller via DriveManager 5 and subsequently terminate the connection 
again. If a trigger event occurs after the disconnection, this can be displayed via the 
“Read oscilloscope data” button after the connection has been re-established.

Options box for serial recordings

11.2.10.3  Comparison of several recordings

For comparison purposes and for the analysis of oscilloscope recordings, it is 
possible to open several recordings at the same time. The icons listed in the table 
are available for this purpose.
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Add additional recordings to the open container

Delete recordings from the container and also from the hard drive

Open a second container. This means these scope recordings can be 
displayed next to each other (using a new horizontal or vertical tab 
group).

Use the  button to open a second container. A second container display appears 
(see upper arrow). The Selector for the recordings (see lower arrow) shows all of the 
recordings that are present in a container.



New window

After a right click on the tab of a container, a prompt appears asking whether the 
windows should be tiled or cascaded.

The measurement function can be used separately for every recording.
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12  Load firmware
The firmware can be transferred to the device from the main menu under Extras > 
Load firmware. When doing so, the wizard decides whether a project already exists 
or not.

NOTE

 l In regard to this topic, the chapter “Serial Commissioning" also 
presents the option of loading an entire firmware package 
(*.comfwarc) with additional components; see Section "Firmware 
package" on page 96.

Procedure: Loading the firmware with an existing project:

 n Establish a connection to a project

 n Main menu under Extras > Load firmware
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 n When the “Start loading operation" button is actuated, a prompt is issued 
requesting that the firmware be selected. The device is put into the bootstrap 
mode. This state is indicated on the display by "L1". The transfer takes place 
when the HEX file is selected . The firmware download may take several 
minutes. The display shown changes during the transfer. The data transfer 
can be recognized in DriveManager 5 by the green bar at the lower right 
edge of the screen.

 

CAUTION! Your system/motor may be damaged if put into operation in 
an uncontrolled or inappropriate manner.

Improper conduct can cause damage to your system / 
machine.

 l Once the firmware has been installed, the controller 
is in the factory setting state. Afterward, either an 
existing or a new device data set must be loaded.

 

Procedure: Loading the firmware without an existing project:



 n Switch off the device or disconnect the 24 V terminal.

 n At the same time as the 24 V control voltage is switched on, press both 
buttons on the display and release them after about 2-3 seconds. The 
controller is in the “bootstrap mode” when "L1" appears in the display.

 n If there is not yet a project present, this message appears:

 n Start load process
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 n Selection of the firmware: Select file. Depending on the device family, the 
firmware file can have the extension *.hex, *.tftp or *.comdvarc. The loading 
operation begins.

NOTE

To be able to transfer the firmware, the controller must be switched off.



13  Serial commissioning

13.1  Introduction
The objective of serial commissioning is to transfer commissioning data (suitable 
firmware, the device settings, etc.) to the drives of a serial machine via 
DriveManager 5 using a single mouse click. The special advantages of this 
procedure include an exceptionally high level of reliability and speed in the transfer 
of the data.

Serial commissioning of single axes

Creating a device commissioning file is sufficient for the serial commissioning of 
individual axes. 
During the transfer of the commissioning files, each device is connected to 
DriveManager 5 ("peer to peer").

Serial commissioning of devices in the network cluster (Ethernet)

For serial commissioning of devices in the network cluster, a project commissioning 
file must always be created. It contains all the commissioning data. 
DriveManager 5 is connected to all devices simultaneously via a “switch”.

The data for a serial commissioning operation are divided into the 
following three file groups.

 l Firmware package

 l Device commissioning file

 l Project commissioning file
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When loading device commissioning files, all types of these files (firmware, device, 
or project commissioning files) are evaluated. The correct loader is started for the 
respective file attachment.



Precondition for serial commissioning:

 l The drives of the reference machine must be put into operation once via 
DriveManager 5.

 l The commissioning files must be created so they are unique.

 l In a single-axis device, each drive must be connected to DriveManager 5 
during the transfer of the commissioning data.

 l In a multiaxial system, the network must be set up.
The addresses must be assigned manually. 
With Ethernet-based fieldbuses, such as EtherCAT, the network topology for 
the service channels is created automatically.
DriveManager 5 is connected to all drives simultaneously via a “switch”.

NOTE

When creating commissioning files, if there is a network cluster, a notice 
is provided automatically indicating the option of creating a project 
commissioning file.
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13.2  Firmware package
File extension: *.comfwarc

The firmware package contains the firmware of all programmable units of a device 
and, depending on the device, has the extension "comfwarc", "comfvarc" or "tftpcom". 
This file can be transferred to a device via a separate loader or using DriveManager 
5 via the main menu under Extras > Load firmware.... The firmware package is 
provided by the device manufacturer and contains the software components 
required for the transfer.



Contents of a firmware package:
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Loading a firmware package with a separate loader without DriveManager 
5

 l Clicking on a desired firmware file opens the following window:

 l Set the connection type

 l Click the “Connect" button

 l Press the start button

NOTE

Firmware packages can be obtained from your service partner.



13.3  Device commissioning file
File extension: *.comdvarc or *.tftpcom

The device commissioning file is sufficient for the serial commissioning of individual 
axes. For serial commissioning of devices in the network cluster, the device 
commissioning files of all devices are grouped into a project commissioning file.
When creating a device commissioning file, the contents must be defined.

Contents of a device commissioning file

Creating a device commissioning file via the button 

The contents are always dependent on the active device and consist of at least two 
sources which must be defined; the firmware package, the device setting (user-
defined parameter data set) and possibly an iPLC program.

The description about this can be found in the Section "Save/Load/Transfer device 
settings" on page 64.
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As an alternative to this, it is also possible to create a device 
commissioning file in the project tree.

To do so, the cursor must be positioned under the communication node in the 
project tree on the relevant device in order open the pop-up menu for defining the 
device commissioning file with the right mouse button.



Loading a device commissioning file

 Start button for loading a device commissioning file.

As an alternative to this, it is also possible to load a device commissioning file in the 
project tree.
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Loading a device commissioning file with the separate loading program

 n Before the transfer, the communication to the DriveManager 5 must be 
interrupted

 n Clicking on an existing device commissioning file opens the following dialog 
box

 n Set the connection type

 n Select file for device commissioning

 n Activate the "Online" button and press the start button



13.4  Project commissioning file
File ending: *.comprjarc

The project commissioning file contains the commissioning data of all devices 
integrated in a project. This only applies for devices in the network cluster.

In addition to the individual device commissioning files, the data for communication 
is also contained.
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Create project commissioning file

1. Call via the main menu under Project > Serial commissioning > Create project 
commissioning file

2. Call via the quick launch bar 

In this case, there is a query whether a commissioning file for the entire project 
(several devices) should be created or only for the active device.



A window opens for saving the entire project and in it, the exact contents of this 
project commissioning file must be defined. The source (device or file) must be 
selected for each individual device.
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Transferring an existing project archive with a separate loader program:

A double-click on the existing project commissioning file (*.comprjarc) opens the 
loader program. Afterwards, just click the Start button and the files will be transferred.



13.5  Transfer error
The following information should be noted if a transfer error occurs.

Measures in the event of a transfer error

If there is an error during the transfer of the project commissioning file, it is possible 
to view the log file protocol with DriveManager 5 or with the separate loader program 
to check the location at which the transfer error occurred.

 

CAUTION! Damage to the device as a result of incorrect operation!

Failure to exercise caution or follow proper working 
procedures may result in damage to the device.

 l After a faulty transfer, do not use the reset function. In 
this case, the transfer must be stopped in the pop-up 
window after about 2 minutes. Only then may the 
loading operation be started again.
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14  Plug-in concept

14.1  Introduction to the plug-in concept
Drive Service Tools installation has changed fundamentally with version 5.6.x of 
DriveManager 5. The complete functionality of all applications is divided into 
packages that can be installed separately. These packages can also be installed or 
uninstalled separately in future. The plug-in concept greatly simplifies installation 
management of software components. For example, you can now easily modify, 
update or replace motor and encoder databases, device packages or even new 
kernel versions as plug-ins.

NOTE

 l Please refer to the DriveManager 5 installation manual for details 
on basic and first-time installation.

During setup installation the program displays the various software components in 
the Application Startup window along with the appropriate version numbers.
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There are three kinds of plug-in packages that can be installed separately:

1. Kernel packages

a. Kernel (interfaces, basic device functions)
b. Kernel visualisation (toolboxes, parameter controls, dialog boxes, 
etc.)

2. Device support packages (plug-in and device data)

3. Applications (DM5, commissioning loaders, etc.)

 

Installing device packages

There are three ways to handle and install device packages or plug-in packages:

 1. From the distribution hot-plug folder (see section Section "Installing device 
packages from the hot-plug folder" on page 104)

 2. Manually, using the Package Manager (PAM)

 3. Automatically, using the PAMCLI (expert tool)



14.2  Installing device packages from the hot-
plug folder
The easiest way to install device packages is to add *.dstpackage files to the 
distribution hot-plug folder. Simply copy the files into the setup directory “..\PlugIn”.

When you run the setup program again, the system recognises all available device 
support packages in the “PlugIn” subfolder and adds them.
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14.3  Package Manager (PAM)

General information about the Package Manager (PAM)

The newly introduced plug-in concept provides the user with a new tool for installing 
or removing device support packages. PAM gives the user an overview of installed 
packages, as well as details and dependencies of the packages. It also allows the 
user to define and manage profiles.



Running PAM manually

Unlike the other applications, such as DriveManager 5, the commissioning loader or 
IP network configuration, the installation does not create an icon on the desktop.

The program can be run from the Windows start menu, as shown. For installation 
purposes, PAM must be run in administrator mode (right click: Run as administrator).

If you don’t launch PAM in administrator mode, all plug-in installation buttons are 
greyed out and you can only view plug-in information.

Running PAM automatically

Double-click on a package file (*.dstpackage) to automatically launch PAM in 
administrator mode and install the package.
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Functions in the installation window



The following window is displayed when you install separate packages or entire 
collections.
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Press the “Details” button for more information about the plug-ins.



Functions in the profile window

The profile window allows you to select special versions of each component, e.g. for 
testing purposes. The “latest version of all” option is enabled by default.

If you run DriveManager 5 without a profile in the command line option or, for 
example, by clicking the installed desktop icon, it automatically loads the latest (or 
only) version of each installed plug-in.
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Creating a new profile

To use an older or special version of one or more device packages, create a new 
profile, i.e. a duplicate of the default profile, and then modify it (duplicate profile). 
Press the “Edit conditions” button to edit specific version conditions.

You can create multiple different profiles. You must load a profile in order to activate 
it.

 



Running DriveManager 5 with a custom profile

To run DriveManager 5 with a custom profile, it must be launched from the command 
line or from a modified desktop icon. This is useful, for example, if you have multiple 
shortcuts on the desktop and you want to run them with different profiles.

Call syntax:
“DriveServiceTool5.exe –profile <Profilename>”

There must be a space between the flag (-profile) and the name of the profile.

You can declare different profile launchers by duplicating/copying the installed 
shortcut and then adding the profile option in “Target:”.
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Information about PAM

 



NOTE

 l PAM always runs with the Windows system language currently 
configured. It is therefore not easy to change language. It is not 
sufficient to simply change the settings in the taskbar’s “Language 
bar” as there you can only change the language region, i.e. the 
default for keyboard, date and currency formats, etc.
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14.4  Overview of active plug-ins
An overview of all active plug-ins is given in DriveManager 5 under Help > 
Information under Details. The user can simply send this list to the Helpline at 
LTI Motion  in the event of an error or if service is required.

Further information on the “E-mail function” can be found in Section "Email function" 
on page 58



15  Initial Commissioning wizard

 

If DriveManager 5 is opened without an existing project, a prompt appears asking 
whether to undertake initial commissioning. The Initial Commissioning wizard can 
also be opened at a later point in time using the quick launch pictogram in the quick 
launch bar (subject area bar).

Selection for carrying out initial commissioning with the wizard

Fig. 15.1: Preselection window for the Initial Commissioning wizard
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Initial Commissioning wizard

The assistant guides the way through the initial commissioning via the individual 
subject areas (power stage > motor > automatic tests ...). When the data are entered 
correctly, rotation of the motor is possible via the manual mode window.

Fig. 15.2: The Initial Commissioning wizard

 



Opening the Initial Commissioning wizard via the project tree

Fig. 15.3: Project window with the Initial Commissioning node in the project tree
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16  Index

"
"Offline” mode 28
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A
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Alarms 62
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Auto Hide 20

Axis status 61
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Bit trigger 73, 77
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Blinking code 42

Bode chart 88

Bootstrap 93

C
Central Oscilloscope Control 73

Channel selection 74

Cockpit 34

Compare settings 71

Complex FFT 88

Container 89-90

Container display 91

Copyright 3

Customize the desktop 18

Customize the search functions 40

Cyclical operations 30

D
Data sets 71

Default desktop 17, 20

Deleting a project 51



Device commissioning file 98

Device display 42

Device Help 11

Device settings 64

Device status 61

Device status window 61

Dialog box view 23

Digital oscilloscope 73

DIN EN 12100 10

Display instruments 34

Display options 30

Display raw device data 77

Dock 19

E
E-mail function 58

E-mail support 31, 58

EN 60204 10

EN 60204-1 10
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Error display 63
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Error history 61

Error message 63

Error reactions 62

F
Fault 62

Faults 61

FFT 87

File extensions 65

Firmware 93, 96

Firmware package 96

Floating 19

Freeze project 52

Frozen Project 52

G
Graphical view 23

H
Help browser 12

Help system 11



Help window 12

History of parameter changes 37

Hot-plug folder 104

I
Initial Commissioning wizard 110

Installation 16

International settings 29

Invalid user input 41

L
Language 29

Language settings 29

LED display 42

List view 23

Load 64

Load firmware 93

Loader program 101

Loading a device commissioning file 70

Loading an oscilloscope recording 83

Logging of parameter changes 38
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M
Macro recorder 38

Malfunction 61

Manual mode window 56

Marker 85

Mathematical functions 86

Measurement function 92

Measurement tool 85

Menu 21

Message logger 36

Messages 35

Mode 93

N
New project 47

Nodes 45

O
Object search 40

Opening a project 50



Options 29, 78, 82

Options window 29

Oscilloscope 73

P
Package Manager 104

PAM 104

Parameter changes history 37

Parameter comparison 71

Parameter help 11, 14

Password 27

Plug-in concept 103

Pre-trigger 73, 77

Print function 42

Print menu 42

Print preview 44

Print settings 43

Printing the device setting 70

Profile launcher 108

Program help 11

Project archive 53
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