
ServoOne
 iPlc   Quick Start Guide

Single-Axis System
Multi-Axis System

Junior



Quick Start Guide iPlc ServoOne

Quick Start Guide for ServoOne

Id.-Nr.: 1107.21B.0-00 EN

Status: 11/2010

We reserve the right to make technical changes.
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How to use the document

Dear User,

This manual is intended for project engineers, commissioning engineers or programmers 
of drive and automation solutions on the CANopen and EtherCAT field bus.

It is assumed that you are already familiar with these field bus systems through appro-
priate training and from reading the relevant literature. We assume that your drive is  
already in operation – if not, you should first consult the Operation Manual.

NOTE: This manual applies to the ServoOne position controller system, 
so you will see only the abbreviation SO used below.

11 Introduction

 22 Use of the iPlc
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Pictograms

! Important! Misoperation may result in damage to the drive or malfunctions.

Danger from electrical voltage! Improper behaviour may endanger human life.

Danger from rotating parts! Drive may start up automatically.

Note: Useful information.



Quick Start Guide iPlc ServoOne 5

Table of contents

 How to use the document .............................................................. 3

1 Introduction ............................................................................. 7
1.1 iPlc Overview ..........................................................................................................7

1.1.1 iPlc  Characteristics ......................................................................................7

1.1.2 Programming Environment ..........................................................................7

1.1.3 iPlc: Implemented Functions ........................................................................7

1.1.4 Performance ................................................................................................7

1.2 Additional Documentation ......................................................................................7

2 Use of the iPlc .......................................................................... 9
2.1 Requirements for using the iPlc ...............................................................................9

2.2 Installation of CoDeSys 3.x ......................................................................................9

2.3 Entering the licence code ........................................................................................9

2.4 Parameter settings in the ServoOne ........................................................................9

2.5 Using the CoDeSys programming system  ...............................................................10

2.5.1 Start CoDeSys 3.x ........................................................................................10

2.5.2 Installation of the ServoOne device description ...........................................10

2.5.3 Installation of the basic motion library .........................................................12

2.5.4 Creation and basic configuration of a new project .......................................12



Quick Start Guide iPlc ServoOne 6



Quick Start Guide iPlc ServoOne 7

[ Chapter 1 ]

1 Introduction

This manual gives a short introduction how to use the iPlc programming interface. 

With this manual the user can start creating own programs which assist and add the 
functions of the ServoOne and ServoOne junior.

1.1 iPlc Overview
A programmable logic controller (PLC) or programmable controller is a 
digital computer used for automation of electromechanical processes, such as control 
of machinery on factory assembly lines, amusement rides, or lighting fixtures. PLCs are 
used in many industries and machines. Unlike general-purpose computers, the PLC is 
designed for multiple inputs and output arrangements, extended temperature ranges, 
immunity to electrical noise, and resistance to vibration and impact. Programs to control 
machine operations are typically stored in battery-backed or non-volatile memory. A PLC 
is an example of a real time system since output results must be produced in response 
to input conditions within a bounded time, otherwise unintended operation will result 
[Wikipedia].

1.1.1 iPlc Characteristics
 • No additional  “PLC hardware” is needed – the iPlc uses free CPU power of the 

ServoOne.

 • No special firmware is needed. The iPlc is already included in the ServoOne firm-
ware (2.20-01 or higher) and in the ServoOne junior firmware (1.10-01 or higher).

 • The PLC needs to be activated by a unique licence code. This licence code needs 
to be entered into the ServoOne by using the LTi DriveManager5. A licence code is 
assigned to one drive. 

1.1.2 Programming Environment
The iPlc uses the CoDeSys 3.x programming environment (based on IEC 61131). This 
programming environment is available in the Downloadarea at http://drives.lt-i.com/, the 
Homepage of LTi DRiVES.

1.1.3 iPlc Implemented Functions
 • CoDeSys 3.x standard functions (e.g. timers, trigger-functions, flip-flops, counter)

 • Functions for single-axis positioning (absolute, relative and endless positioning)

 • motor control (Start, Stop, Quickstop, Halt)

 • status and diagnosis

 • Read and write access to all parameters

 • Access to in-/outputs

1.1.4 Performance
The speed is limited by the free CPU power (typically cycle times down to 1 ms are possi-
ble, 5ms are recommended).

The iPlc performance depends on the activated functions (e.g. motor control type, 
profile-generation, field-bus-communication) in the ServoOne.

Cyclic access to predefined parameters: analog and digital I/O and PLC-Parameters (10 x 
real, 20 x integer, 20 x double-integer).

1.2 Additional Documentation
Please notice that our additional Documentation is available in the Downloadarea at 
http://drives.lt-i.com/.

 • ServoOne operation manual

 • ServoOne application manual
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3S-Smart Software Solutions GmbH also provides an online help for the CoDeSys pro-
gramming system.

Figure 1.1  CoDeSys Help
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[ Chapter 2 ]

2 Use of the iPlc

2.1 Requirements for using the iPlc
 • LTi ServoOne with iPlc licence 

 • ServoOne software “DriveManager5” (V5.3.9 or above) 

 • CoDeSys 3.x programming system 

 • ServoOne drive description 1.1.1.0 or higher   

 • ServoOne basic motion library 1.1.4.2 or higher 

 • ServoOne standard library 1.0.0.0 or higher  

The DriveManager Software, the CoDeSys programming system, the device description 
and the libraries are available on our homepage http://drives.lt-i.com/ (Downloadarea).

The ServoOne can be ordered together with an iPlc licence. These ServoOne contains a 
“1” within the model number.

ServoOne : SO8X.xxx.xxxx.x1xx.x

ServoOne junior : SO2X.xxx.xxxx.x1xx.x 

The licence code can also be ordered separately and the iPlc functionality can be added 
later on together with the serial number. The ordering number for a single PLC-licence is 
1100.0000.0100.0.

2.2 Installation of CoDeSys 3.x
 • Unzip the CoDeSys 3.x files and store these in a local directory on your computer.

 • Double click onto the installation file.

 • Follow the instructions during the installation process.

2.3 Entering the licence code
If the iPlc licence is ordered separately it will be required to enter the licence code manu-
ally. 

 • Open the DriveManager5

 • Enter the four digit iPlc licence code in parameter P693 (Drive settings -> Administ-
ration -> Licence).

 • Store value in the non volatile memory

 • Reboot the device

Figure 2.1  Software Licence

2.4 Parameter settings in the ServoOne
There are several possibilities to use the iPlc:

 • Start the motor control via iPlc

 • Reference value command via iPlc

 • Calculations 

 • Additional monitoring

 • And much more

When the iPlc is not used for motor control or reference value command, no additional 
settings in the DriveManager are necessary. 

Otherwise the following settings must be done: 
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Parameter Name Parameter No. Setting

MPRO_CTRL_SEL P159 sub 0 PLC(4) = via IEC61131 program

MPRO_REF_SEL P165 sub 0 PLCbasic(4) = via PLC basic library

CON_CfgCon P300 sub0 PCON(3) = Position control mode

CON_REF_Mode P301 sub 0
PG(0) = setpoint effects to profile 
generator

MPRO_DRVCOM_AUTO_START P144 sub 0
ON(1) = Start/restart drive automatically 
in case of power or fault

Table 2.1 Parameter

Figure 2.2  Set control, reference and profile mode

Figure 2.3  Control mode

2.5 Using the CoDeSys programming system 

2.5.1 Start CoDeSys 3.x
To start CoDeSys 3.x click on the desktop symbol 

2.5.2 Installation of the ServoOne device description
The device description contains information for CoDeSys which are nessascary to get 
access to the device.

The device description needs to be installed only once. 

 • Download the device description from our Homepage http://drives.lt-i.com/ 
(Downloadarea).

 • Open Device Repository window (Tools -> Device Repository)

 • Click on “Install…” 

 • Choose and install the device description from folder.

 • Make sure that “Device description files” is chosen as file type.

 • Close window
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Figure 2.4  Device Repository
Figure 2.5  Device description
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2.5.3 Installation of the basic motion library
The ServoOne basic motion library contains drive specific functions like enable / disable-
functions and also motion control functions.

The basic motion library needs to be installed only once. 

 • Open the library repository window (Tools -> Library repository).

 • Click on “Install…” 

 • Choose and install ServoOne basic motion library from folder.

 • Close window

Figure 2.6  Library Repository

The ServoOne standard library contains adjusted functions and must also be installed.

 • Open the library repository window (Tools -> Library repository).

 • Click on “Install…” 

 • Choose and install ServoOne standard library from folder.

 • Close window

2.5.4 Creation and basic configuration of a new project
A project contains all the information CoDeSys needs to produce the software, which 
finally will be downloaded to the ServoOne. The project contains program code, used 
libraries and task configurations. 
 

 • Start CoDeSys 3.x   

 • Open a new project (File-> New Project…) 

 • Click on “Standard project”

 • Confirm with “OK”

Figure 2.7  New Project

The device description for the ServoOne is already installed. As a result it is possible to 
choose the ServoOne as the Device. Below you can choose your IEC language. In this 
case please choose Structured Text (ST).
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[ Chapter 2 ]

Figure 2.8  Standard Project

After confirming with “OK” you can see the User Interface Components:

Figure 2.9 

Devices window
Editor window

Tool Bar
Menu Bar

Messages window
POUs window

 User Interface Components

 • Menu Bar: Provides menus which contain all currently available commands

 • Tool Bar: Contains tool buttons for all currently available tools 

 • ToolBox window: Provides editor-specific tools (open from View menu)

 • POUs window (view): For organizing the programming units (POUs, DUTs etc

 • Devices window (view): For organizing the device resource objects

 • Editor window (view): Used for creating the particular object in the respective 
editor.

 • Messages Window: Precompile, Compile, Build, Download messages etc. are dis-
played in this window (message view).
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In the Devices window you find the three main parts of a CoDeSys application:

 • POU (PLC_PRG)

 • Library Manager

 • Task Configuration

Figure 2.10  Project tree

POUs (Program Organisation Units) contain mostly the program code of the 
project.

The Task configuration contains the task of a project. A task calls one or more POUs 
within the project frequently. The Library manager contains all libraries which are 
needed in the project.

Now you must add the ServoOne basic motion library to the library manager.

The ServoOne standard library will be automaticly included.

 • Choose “Add Library…” out of the “Libraries” menu

 • Select „ServoOne basic motion library“

 • Click on “OK”

Figure 2.11  Adding a library to the Library Manager

After that, you can start to write your iPlc program in the editor window by opening the 
POU (PLC_PRG).
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[ Chapter 2 ]

Figure 2.12  Editor window

In the following step the Gateway has to be configurated. Select the Gateway and click 
on “Scan network”.  After that select your ServoOne and click on “Set active path”.

This command sets the currently selected communication channel as the active one, 
which means that all actions concerning communication will exactly refer to this channel.

Figure 2.13  Configuration of the gateway

Figure 2.14  Toolbar Login

Then click on Login to    or Alt+F5.

After that the “Device User Logon” window appears. The User Name and the Password 
is “root”. 
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Figure 2.15  Device User Logon window

Now you can start the application by clicking the blue start arrow or F5.

Figure 2.16  Toolbar Start

The iPlc program is now running.
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